<!DOCTYPE html>
<!--[if lt IE 8]>      <html class="lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="lt-ie9"> <![endif]-->
<!--[if IE 9]>         <html class="lt-ie10"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en"> <!--<![endif]-->
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width initial-scale=1 maximum-scale=1 user-scalable=no">
    <meta name="msvalidate.01" content="43434ADDF3F60D7897F819F388E2FADF">
    <title>Newly engaged Meghan Markle is leaving &#x27;Suits&#x27; after Season 7 - TODAY.com</title>
    <meta name="author" content="Gina Vivinetto">
    <meta property="og:description" content="The actress, whose engagement to Prince Harry was announced this week, has played attorney Rachel Zane on the USA legal drama since the show&#x27;s 2011 debut.">
    <meta name="description" content="The actress, whose engagement to Prince Harry was announced this week, has played attorney Rachel Zane on the USA legal drama since the show&#x27;s 2011 debut.">
        <meta property="og:title" content="Meghan Markle leaving &#x27;Suits&#x27; because she has something else going on">
        <meta name="twitter:title" content="Meghan Markle leaving &#x27;Suits&#x27; because she has something else going on">
    <meta property="og:site_name" content="TODAY.com">
    <meta property="og:type" content="article">
    <meta property="og:image" content="https://media3.s-nbcnews.com/i/newscms/2017_48/1299975/meghan-markle-today-171121-tease_79e1c5b624ea98df7b78a2c779eafbdb.jpg">
    <meta property="og:url" content="https://www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387">
    <meta property="fb:app_id" content="122384521533">
    <meta property="fb:admins" content="100001657893615">
    <meta property="fb:pages" content="12566691349">
    <meta property="fb:pages" content="43060543381">
    <meta property="fb:pages" content="877272149009111">
    <meta property="fb:pages" content="363939277982">
    <meta property="fb:pages" content="833762920078637">
    <meta property="fb:pages" content="1228114460538309">
    <meta property="fb:pages" content="184293318271345">
    <meta property="fb:pages" content="157687092983">
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TodayShow">
    <meta name="twitter:description" content="The actress, whose engagement to Prince Harry was announced this week, has played attorney Rachel Zane on the USA legal drama since the show&#x27;s 2011 debut.">
    <meta name="twitter:creator" content="@TodayShow">
    <meta name="twitter:domain" content="TODAY.com">
    <meta name="twitter:image:src" content="https://media3.s-nbcnews.com/j/newscms/2017_48/1299975/meghan-markle-today-171121-tease_79e1c5b624ea98df7b78a2c779eafbdb.today-inline-vid-featured-desktop.jpg">
    <meta name="parsely-post-id" content="119387">
        <meta name="news_keywords" content="Royals ,Pop Culture,News,TV">
    <meta name="google-site-verification" content="uDRXhvw8LRHhorJhIUmXCkUPjqGebM6KFh9jZGwH6VA">
        <meta name="DC.date.issued" content="2017-11-28T23:00:00.000Z">
    <link rel="canonical" href="https://www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387">
      <link rel="amphtml" href="https://www.today.com/amp/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387">
    <link rel="apple-touch-icon" href="https://media1.s-nbcnews.com/i/MSNBC/Components/ArtAndPhoto-Fronts/SITEWIDE/Bullets_BackgroundGIFs/today-apple-touch-icon2.png">
    <link rel="shortcut icon" href="https://media1.s-nbcnews.com/i/MSNBC/Components/Interactives/_swf/Today/COVER/today-favicon.ico">
    <meta name="apple-itunes-app" content="app-id=416357699, affiliate-data=ct=todaycom_sb&pt=211554, app-argument=https://www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387">

        <link type="text/css" rel="stylesheet" href="https://nodeassets.today.com/styles/main-desktop-d72690d663.min.css">
      <noscript>
          <link type="text/css" rel="stylesheet" href="https://nodeassets.today.com/styles/secondary-88bc0a721a.min.css">
      </noscript>
    
    
    
    


        <script src="https://www.google.com/cloudprint/client/cpgadget.js">
        </script>

    <script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "WebSite",
      "url": "http://www.today.com/",
      "potentialAction": {
        "@type": "SearchAction",
        "target": "http://www.today.com/search?query={search_term_string}",
        "query-input": "required name=search_term_string"
      }
    }
    </script>


                    <script>var w=window;if(w.performance||w.mozPerformance||w.msPerformance||w.webkitPerformance){var d=document;AKSB=w.AKSB||{},AKSB.q=AKSB.q||[],AKSB.mark=AKSB.mark||function(e,_){AKSB.q.push(["mark",e,_||(new Date).getTime()])},AKSB.measure=AKSB.measure||function(e,_,t){AKSB.q.push(["measure",e,_,t||(new Date).getTime()])},AKSB.done=AKSB.done||function(e){AKSB.q.push(["done",e])},AKSB.mark("firstbyte",(new Date).getTime()),AKSB.prof={custid:"378086",ustr:"",originlat:"0",clientrtt:"62",ghostip:"96.17.8.13",ipv6:false,pct:"10",clientip:"54.224.77.253",requestid:"18984b0e",region:"20244",protocol:"",blver:13,akM:"g",akN:"ae",akTT:"O",akTX:"1",akTI:"18984b0e",ai:"217263",ra:"false",pmgn:"",pmgi:"",pmp:"",qc:""},function(e){var _=d.createElement("script");_.async="async",_.src=e;var t=d.getElementsByTagName("script"),t=t[t.length-1];t.parentNode.insertBefore(_,t)}(("https:"===d.location.protocol?"https:":"http:")+"//ds-aksb-a.akamaihd.net/aksb.min.js")}</script>
                    </head>
<body class="entrypage no-js desktop" data-page-type="j-entrypage" data-context="j-entrypage">

    <script>document.body.className = document.body.className.replace('no-js', '');</script>



    <div class="content clearfix">
        
        <header id="header">
          <div class="header-l-navigation">
            <div class="header-wrapper">
                <div class="header-logo"><a href="//www.today.com/"><span>Today.com</span><img src="https://nodeassets.today.com/cdnassets/today-images/tdy-header-logo.png" srcset="https://nodeassets.today.com/cdnassets/today-images/tdy-header-logo@2x.png 2x"></a></div>
              <div class="header-l-wrapper">
                <div class="header-l-sections">
                  <ul>
                  	<li class="header-spotlight"><a class="j-nav-main" href="//www.today.com/video">Video</a></li>
                  	<li class="header-spotlight"><a class="j-nav-main" href="//www.today.com/food">Food</a></li>
                  	<li class="header-spotlight"><a class="j-nav-main" href="//www.today.com/health">Health & Wellness</a></li>
                  	<li class="header-spotlight"><a class="j-nav-main" href="//www.today.com/style">Style</a></li>
                  	<li class="header-spotlight"><a class="j-nav-main" href="//www.today.com/home">Home</a></li>
                  	<li class="header-spotlight"><a class="j-nav-main" href="//www.today.com/parents">Parents</a></li>
                  </ul>
                </div>
                <label id="header-menu" class="header-more j-header-menu header-spotlight" for="nav-handler">
                  <span>More</span>
                  <i class="icon-arrow-down"></i>
                  <i class="icon-menu"></i>
                </label>
                <div class="header-l-side">
                  <div class="header-search header-spotlight j-icon-search">
                    <span class="header-search-text">Search</span>
                    <i class="icon-search"></i>
                  </div>
                  <div class="header-l-search">
                    <form id="hdr-search" action="/search" class="hdr-search">
                      <input class="hdr-search-input" name="query" type="text" size="20" value="" placeholder="search">
                      <input value="Go" class="hdr-search-submit j-header-search-submit" type="submit">
                    </form>
                  </div>
                  <div class="header-share-wrapper j-header-follow-us">
                    <i class="icon-share"></i>
                    <div class="header-l-social j-header-social-expand">
                    	<a class="j-nav-social-follow" href="http://www.facebook.com/today" title="Facebook" alt="Facebook"><i class="icon-facebook"></i></a>
                    	<a class="j-nav-social-follow" href="https://twitter.com/intent/follow?region=follow_link&screen_name=TodayShow" title="Twitter" alt="Twitter"><i class="icon-twitter"></i></a>
                    	<a class="j-nav-social-follow" href="http://pinterest.com/todayshow/" title="Pinterest" alt="Pinterest"><i class="icon-pinterest"></i></a>
                    	<a class="j-nav-social-follow" href="http://instagram.com/todayshow" title="Instagram" alt="Instagram"><i class="icon-instagram"></i></a>
                    	<a class="j-nav-social-follow" href="https://secure.today.com/_tps/_accounts/msnbc/newsletters?categoryFilter=today" title="Newsletter" alt="Newsletter"><i class="icon-email"></i></a>
                    </div>          </div>
                  <div class="header-social-wrapper header-spotlight j-header-follow-us">
                    <div class="header-l-social">
                    	<a class="j-nav-social-follow" href="http://www.facebook.com/today" title="Facebook" alt="Facebook"><i class="icon-facebook"></i></a>
                    	<a class="j-nav-social-follow" href="https://twitter.com/intent/follow?region=follow_link&screen_name=TodayShow" title="Twitter" alt="Twitter"><i class="icon-twitter"></i></a>
                    	<a class="j-nav-social-follow" href="http://pinterest.com/todayshow/" title="Pinterest" alt="Pinterest"><i class="icon-pinterest"></i></a>
                    	<a class="j-nav-social-follow" href="http://instagram.com/todayshow" title="Instagram" alt="Instagram"><i class="icon-instagram"></i></a>
                    	<a class="j-nav-social-follow" href="https://secure.today.com/_tps/_accounts/msnbc/newsletters?categoryFilter=today" title="Newsletter" alt="Newsletter"><i class="icon-email"></i></a>
                    </div>          </div>
                  <div class="header-shop-wrapper header-spotlight j-header-shop">
                    <a href="http://www.today.com/label/shopping">
                      <span class="header-shop-text">Shop</span>
                      <i class="icon-cart"></i>
                    </a>
                  </div>
                  <div class="today-zinger j_zinger2_menu"></div>
                </div>
              </div>
              <nav id="navigation" class="navigation dropdown" role="navigation">
                  <div class="navigation-l navigation-l-sections">
                    <ul class="navigation-l-wrapper">
                          <li class="navigation-l-links first">
                            <i class="icon-video-play"></i>
                            <a class="nav-links j-nav-more" href="//www.today.com/video" title="Watch Video">Watch Video</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="//www.today.com/food" title="Food: Recipes, Cooking Tips, Celebrity Chef Ideas &amp; Food News">Food</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="http://community.today.com/foodclub" title="Food Club">Food Club</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="//www.today.com/food/recipes" title="Recipes: Easy Recipes and Cooking Tips from the TODAY Show">Recipes</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="//www.today.com/health" title="Health &amp; Wellness: Nutrition, Fitness, Diet, Relationships &amp; More  ">Health &amp; Wellness</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="//www.today.com/style" title="Style: Fashion Trends, Beauty Tips, Hairstyles &amp; Celebrity Style News">Style</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="//www.today.com/home" title="Home: Decorating Ideas, Home Improvement, Cleaning &amp; Organization Tips ">Home</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="//www.today.com/parents" title="Parents: Parenting News &amp; Advice for Moms and Dads">Parents</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="http://community.today.com/parentingteam" title="Parenting Team">Parenting Team</a>
                          </li>
                          <li class="navigation-l-links">
                            <a class="nav-links j-nav-more" href="//www.today.com/klgandhoda" title="Kathie Lee and Hoda: News, Photos &amp; Videos from the show">Kathie Lee &amp; Hoda</a>
                          </li>
                    </ul>
                    <ul class="navigation-l-wrapper">
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/megyn-kelly-today" title="Megyn Kelly TODAY">Megyn Kelly TODAY</a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/sunday-today" title="Sunday TODAY with Willie Geist">Sunday TODAY</a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/news" title="TODAY News - Latest News Stories from the TODAY show">News</a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/news/good-news" title="Good News: Inspirational, Hopeful and Uplifting News Stories">Good News</a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/popculture" title="Pop Culture: Entertainment and Celebrity News, Photos &amp; Videos">Pop Culture</a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/popculture/citi-concert-series" title="Citi Concert Series">Concert Series</a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/pets" title="Pets &amp; Animals: Funny Photos, Cute Animal Videos &amp; Pet News">Pets &amp; Animals</a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/store" title="Shop TODAY">Shop TODAY</a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/money/your-money" title="Your money">Your Money </a>
                        </li>
                        <li class="navigation-l-links">
                          <a class="nav-links j-nav-more" href="//www.today.com/kindness" title="#ShareKindness: Get in the Holiday Spirit">Share Kindness </a>
                        </li>
                    </ul>
                  </div>
                <div class="nav-l-search">
                  <form id="nav-search" action="/search" class="nav-search">
                    <input class="nav-search-input" name="query" type="text" size="20" value="" placeholder="search TODAY">
                    <input value="Go" class="nav-search-submit j-header-search-submit" type="submit">
                  </form>
                </div>
                <div class="nav-l-links">
                  <li class="nav-item">
                    <a href="http://www.nbcuni.com/privacy/full-privacy-policy">Privacy policy</a>
                  </li>
                  <li class="nav-item nav-item-border">
                    <a id="_bapw-link" href="http://info.evidon.com/pub_info/1241?" target="_blank"><img id="_bapw-icon" src="https://c.betrad.com/pub/icon1.png">  &nbsp;AdChoices</a>
                  </li>
                </div>
              </nav>
            </div>
          </div>
        </header>
      <script>
    var analyticsDataLayer = {"pageName":"today:article:post:newly-engaged-meghan-markle-leaving-suits-after-season-7","channelSection":"popculture","mobile":"false","platform":"desktop","page":"article","section":"popculture","topic":"tv","subSection":"","label":"royals","show":"","seriesName":"","anchor":"","contentType":"post","headline":"It's official: Meghan Markle will leave 'Suits' at the end of Season 7","breakingNews":false,"modifiedDate":"2017-11-28T23:32:12.000Z","publishDate":"2017-11-28T23:00:00.000Z","documentID":"119387","linkName":"","linkSection":"","searchTerms":"","byline":"Gina Vivinetto","contentSource":"TODAY","canonicalUrl":"https://www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387","videoPresent":1,"ga":{},"amp":{}};
</script>

<main class="content-wrapper">
  <section class="entry-panel" id="j-entry-panel">

      <div itemscope itemtype="http://schema.org/NewsArticle">
      <meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://google.com/article"/>
      
      
      <article class="entry j-entry" data-share-image-url="https://media3.s-nbcnews.com/i/newscms/2017_48/1299975/meghan-markle-today-171121-tease_79e1c5b624ea98df7b78a2c779eafbdb.jpg" data-next-articles="[&quot;/ajax/article/meghan-markle-s-caesar-salad-recipe-t119367&quot;,&quot;/ajax/article/anne-hathaway-buys-home-westport-connecticut-t119324&quot;,&quot;/ajax/article/see-nick-jonas-ed-sheeran-others-perform-bed-benefit-sick-t119319&quot;,&quot;/ajax/article/meghan-markle-was-once-deal-or-no-deal-case-model-t119351&quot;,&quot;/ajax/article/meghan-markle-s-suits-fiance-had-hilarious-response-her-engagement-t119329&quot;,&quot;/ajax/article/elf-shelf-turns-10-secret-history-santa-s-little-scout-t62531&quot;,&quot;/ajax/article/prince-harry-proposed-meghan-markle-cozy-night-while-roasting-chicken-t119321&quot;,&quot;/ajax/article/aladdin-stars-old-new-pay-tribute-disney-classic-s-25th-t119308&quot;,&quot;/ajax/article/suzanne-somers-reveals-key-40-year-marriage-how-avoid-arguments-t119250&quot;,&quot;/ajax/article/james-cameron-tired-hearing-jack-could-have-lived-titanic-t119310&quot;]" data-canonical-url="https://www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387" data-id="119387" data-share-headline="Meghan%20Markle%20leaving%20&#x27;Suits&#x27;%20because%20she%20has%20something%20else%20going%20on" data-seo-headline="Newly engaged Meghan Markle is leaving &#x27;Suits&#x27; after Season 7" data-mpscall="{&quot;cag[primary_section]&quot;:&quot;popculture&quot;,&quot;cag[primary_topic]&quot;:&quot;tv&quot;,&quot;cag[primary_subtopic]&quot;:&quot;&quot;,&quot;cag[primary_label]&quot;:&quot;royals&quot;,&quot;cag[primary_show]&quot;:&quot;&quot;,&quot;cag[entryno]&quot;:1,&quot;type&quot;:&quot;post&quot;,&quot;is_content&quot;:1,&quot;cag[breaking_news]&quot;:0,&quot;cag[byline]&quot;:&quot;Gina Vivinetto&quot;,&quot;cag[series]&quot;:&quot;&quot;,&quot;cag[anchors]&quot;:&quot;&quot;,&quot;cag[shows]&quot;:&quot;&quot;,&quot;cag[sections]&quot;:&quot;popculture|news&quot;,&quot;cag[labels]&quot;:&quot;royals&quot;,&quot;cag[topics]&quot;:&quot;tv&quot;,&quot;cag[subtopics]&quot;:&quot;&quot;,&quot;cag[external_id]&quot;:&quot;119387&quot;,&quot;taxonomy&quot;:&quot;popculture,tv&quot;,&quot;cat&quot;:&quot;popculture|tv&quot;,&quot;path&quot;:&quot;/popculture/tv/newly-engaged-meghan-markle-leaving-suits-after-season-7-119387&quot;}" data-analytics="{&quot;pageName&quot;:&quot;today:article:post:newly-engaged-meghan-markle-leaving-suits-after-season-7&quot;,&quot;channelSection&quot;:&quot;popculture&quot;,&quot;mobile&quot;:&quot;false&quot;,&quot;platform&quot;:&quot;desktop&quot;,&quot;page&quot;:&quot;article&quot;,&quot;section&quot;:&quot;popculture&quot;,&quot;topic&quot;:&quot;tv&quot;,&quot;subSection&quot;:&quot;&quot;,&quot;label&quot;:&quot;royals&quot;,&quot;show&quot;:&quot;&quot;,&quot;seriesName&quot;:&quot;&quot;,&quot;anchor&quot;:&quot;&quot;,&quot;contentType&quot;:&quot;post&quot;,&quot;headline&quot;:&quot;It&#x27;s official: Meghan Markle will leave &#x27;Suits&#x27; at the end of Season 7&quot;,&quot;breakingNews&quot;:false,&quot;modifiedDate&quot;:&quot;2017-11-28T23:32:12.000Z&quot;,&quot;publishDate&quot;:&quot;2017-11-28T23:00:00.000Z&quot;,&quot;documentID&quot;:&quot;119387&quot;,&quot;linkName&quot;:&quot;&quot;,&quot;linkSection&quot;:&quot;&quot;,&quot;searchTerms&quot;:&quot;&quot;,&quot;byline&quot;:&quot;Gina Vivinetto&quot;,&quot;contentSource&quot;:&quot;TODAY&quot;,&quot;canonicalUrl&quot;:&quot;https://www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387&quot;,&quot;videoPresent&quot;:1,&quot;ga&quot;:{},&quot;amp&quot;:{}}" data-formfactor="desktop" data-mps-url="mps.nbcnews.com" data-ecommerce-enabled="false">
      
        <div class="entry-top">
          <a href="/popculture">
            <h2>Pop Culture</h2>
          </a>
          <h1 class="entry-headline j-entry-headline" itemprop="headline">It&#x27;s official: Meghan Markle will leave &#x27;Suits&#x27; at the end of Season 7</h1>
          <div class="entry-byline">
                <div class="byline-image-column">
                  <img class="byline-image" src="https://media1.s-nbcnews.com/j/newscms/2015_33/730066/gina-vivinetto-byline-photo-today-150813_0564f90c3098d0c60aebe664cef423a5.today-byline.jpg">
                </div>
            <div class="byline">
              <time style="display:none" class="entry-time" itemprop="dateModified" content="2017-11-28"></time>
              <time class="entry-time" itemprop="datePublished" content="2017-11-28">2017-11-28T23:00:00.000Z</time>
      <div class="byline-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name">Gina Vivinetto</span></div>        <div class="byline-affiliation" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
                <span itemprop="name">TODAY</span>
                <img style="display:none"  itemprop="logo" url="https://media1.s-nbcnews.com/j/newscms/2015_33/730066/gina-vivinetto-byline-photo-today-150813_0564f90c3098d0c60aebe664cef423a5.today-byline.jpg">
                <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                  <meta itemprop="url" content="https://nodeassets.today.com/cdnassets/today-images/today-logo.png">
                  <meta itemprop="height" content="25">
                  <meta itemprop="width" content="167">
                </div>
              </div>
            </div>
          </div>
        </div>
      
      
            
            <section class="side-panel">
            
            </section>
      
        <div class="entry-container" data-share-image-url="https://media3.s-nbcnews.com/i/newscms/2017_48/1299975/meghan-markle-today-171121-tease_79e1c5b624ea98df7b78a2c779eafbdb.jpg" data-share-url="//www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387" data-headline="It&#x27;s official: Meghan Markle will leave &#x27;Suits&#x27; at the end of Season 7" data-share-headline="Meghan%20Markle%20leaving%20&#x27;Suits&#x27;%20because%20she%20has%20something%20else%20going%20on" data-section="popculture" itemprop="articleBody">
          <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://media3.s-nbcnews.com/i/newscms/2017_48/1299975/meghan-markle-today-171121-tease_79e1c5b624ea98df7b78a2c779eafbdb.jpg">
            <meta itemprop="width" content="1920">
            <meta itemprop="height" content="1080">
          </div>
                <div class="entry-social-marker"></div>
                <aside class="entry-social left j-share-bar-left" data-share-image-url="https://media3.s-nbcnews.com/i/newscms/2017_48/1299975/meghan-markle-today-171121-tease_79e1c5b624ea98df7b78a2c779eafbdb.jpg" data-share-url="//www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387" data-share-headline="Meghan%20Markle%20leaving%20&#x27;Suits&#x27;%20because%20she%20has%20something%20else%20going%20on" data-section="popculture">
                  
                  <div class="btn btn-facebook j-facebook">
                    <i class="icon-facebook j-article-share j-facebook" platform="facebook"></i>
                    <span class="label-facebook j-facebook j-share-label">share</span>
                  </div>
                  
                  <div class="btn btn-twitter j-twitter">
                    <i class="icon-twitter j-article-share j-twitter" platform="twitter"></i>
                    <span class="label-twitter j-twitter j-share-label">tweet</span>
                  </div>
                  
                  <div class="btn btn-pinterest j-pinterest">
                    <i class="icon-pinterest j-article-share j-pinterest" platform="pinterest"></i>
                    <span class="label-pinterest j-pinterest j-share-label">pin</span>
                  </div>
                  
                  <div class="btn btn-email j-email">
                    <i class="icon-email j-article-share j-email" platform="email"></i>
                    <span class="label-email j-email j-share-label">email</span>
                  </div>
                </aside>
      
      
            <p>
        Meghan Markle's fans will have to be satisfied seeing her shine on the world stage — because she's leaving the small screen behind.
      </p>
      
            <p>
        The 36-year-old actress, who announced <a href="https://www.today.com/news/prince-harry-engaged-meghan-markle-here-are-details-t109215" target="_blank">her engagement to Prince Harry </a>this week, will be leaving the cast of "Suits" at the end of Season 7, the USA Network announced on Tuesday.
      </p>
      
            <div class="inline-img-container">
          <figure class="entry-img retina-enabled">
              <img class="j-entry-img" src="https://media3.s-nbcnews.com/j/newscms/2017_48/1299975/meghan-markle-today-171121-tease_79e1c5b624ea98df7b78a2c779eafbdb.today-inline-large.jpg" alt="" title="Image: Suits - Season 4">
                      <small class="entry-img-credit">Nigel Parry/USA Network</small>
                  <div class="entry-img-caption">Meghan Markle has played attorney Rachel Zane for several years on &quot;Suits,&quot; which returns in early 2018.</div>
      	</figure>
      </div>
      
            <p>
        "From all of us at USA Network and Universal Cable Productions, we want to send our most heartfelt congratulations to Meghan Markle and Prince Harry on their engagement," <a href="http://www.usanetwork.com/suits/blog/meghan-markle-leaves-suits" target="_blank">a statement posted on the network's website read. </a>
      </p>
      
            <p>
        "Meghan has been a member of our family for seven years and it has been a joy to work with her. We want to thank her for her undeniable passion and dedication to 'Suits,' and we wish her the very best."
      </p>
      
            <div itemprop="video" itemscope itemtype="http://schema.org/VideoObject" class="video-wrapper j-video-wrapper inline j-inline" data-canonicalUrl="https://www.today.com/video/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709" data-thumbnail="https://media4.s-nbcnews.com/j/MSNBC/Components/Video/201711/1920_kate_Screen_Shot_2017-11-28_at_3-04-30_PM.today-inline-vid-featured-desktop.jpg" data-title="Duchess Kate is &#x27;thrilled&#x27; over Meghan Markle and Prince Harry&#x27;s engagement news!" data-mpx-id="1105288259709">
        <div class="player-closedcaption">
        	<header>Closed Captioning</header>
        	<div class="switch">
              <input type="radio" class="switch-input" name="view" value="week" id="week" checked="">
              <label for="week" class="switch-label switch-label-off">ON</label>
              <input type="radio" class="switch-input" name="view" value="month" id="month">
              <label for="month" class="switch-label switch-label-on">OFF</label>
              <span class="switch-selection"></span>
            </div>
            <div class="actions-box control-cc-close">
        			apply | reset <span class="close-box"> x </span>
            </div>
        	<ul class="cc-nav">
        		<li class="tabselect"><a href="#">Text Display</a></li>
        		<li><a href="#">Background</a></li>
        		<li><a href="#">Enhancements</a></li>
        	</ul>
            <div class="tab1">
            	<div class="of-three">
            		font<br>
            		<select>
        			  <option value="times">Times New Roman</option>
        			  <option value="arial">Arial</option>
        			  <option value="comicsans">Comic Sans</option>
        			</select>
            	</div>
            	<div class="of-three">
            		size<br>
            		<div class="textsize xsmall">T</div> <div class="textsize select">T</div> <div class="textsize medium">T</div> <div class="textsize large">T</div>
            	</div>
            	<div class="of-three">
            		color<br>
            		<div class="colorblock-select select"> </div>
            		<div class="colorblock black"> </div> <div class="colorblock blue"> </div> <div class="colorblock green"> </div> <div class="colorblock cyan"> </div><br>
            		<div class="colorblock black"> </div> <div class="colorblock blue"> </div> <div class="colorblock green"> </div> <div class="colorblock cyan"> </div>
            	</div>
            </div>
        </div>  <meta itemprop="duration" content="P42S">
        <meta itemprop="contentUrl" content="https://www.today.com/offsite/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709">
        <meta itemprop="description" content="Duchess Kate said she and Prince William are delighted about Meghan Markle and Prince Harry&#x27;s upcoming nuptials! And, Markle is a big fan of Kate, too.">
        <meta itemprop="name" content="Duchess Kate is &#x27;thrilled&#x27; over Meghan Markle and Prince Harry&#x27;s engagement news!">
        <meta itemprop="thumbnailUrl" content="https://media4.s-nbcnews.com/j/MSNBC/Components/Video/201711/1920_kate_Screen_Shot_2017-11-28_at_3-04-30_PM.today-inline-vid-featured-desktop.jpg">
        <meta itemprop="uploadDate" content="2017-11-28T20:03:39.000+0000">
                  <div class="content-social player-social j-player-social-header" data-share-url="//www.today.com/video/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709" data-embed="%3Cdiv%20style&#x3D;%22position:relative;%20padding-bottom:63%25;%20padding-bottom:-webkit-calc(56.25%25%20+%2050px);%20padding-bottom:calc(56.25%25%20+%2050px);%20height:%200;%22%3E%0A%20%20%20%20%3Ciframe%20style&#x3D;%22position:absolute;%20width:%20100%25;%20height:%20100%25;%22%0A%20%20%20%20src&#x3D;%22https://www.today.com/offsite/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709%22%20scrolling&#x3D;%22no%22%20frameborder&#x3D;%220%22%3E%3C/iframe%3E%0A%20%20%3C/div%3E" data-share-headline="Duchess%20Kate%20is%20&#x27;thrilled&#x27;%20over%20Meghan%20Markle%20and%20Prince%20Harry&#x27;s%20engagement%20news!" data-video-guid="x_tdy_TOV_NEWS_KATEREACTS_171128">
                  	<div class="btn-v btn-facebook j-player-social j-facebook" data-platform="facebook">
                  		<i class="icon-facebook j-facebook"></i>
                  	</div>
                  	<div class="btn-v btn-twitter j-player-social j-twitter" data-platform="twitter">
                  		<i class="icon-twitter j-twitter"></i>
                  	</div>
                  	<div class="btn-v btn-email j-player-social j-email" data-platform="email">
                  		<i class="icon-email j-email"></i>
                  	</div>
                  	<div class="btn-v btn-embed j-player-social j-embed" data-platform="embed">
                  		<i class="icon-embed"></i>
                  	</div>
                  	<div class="btn-v share-url button j-player-social j-link">share link</div>
                  	<div class="player-l-shareCode-panel j-shareCode-panel">
                  		<i class="icon-close"></i>
                  		<input class="j-shareCode-input player-shareCode-input" value="" type="text" name="codebox" onClick="this.select()" readonly>
                  	</div>
                  </div>
      
        <div class="player-l-container j-video-tease j-video-wrapper-tease retina-enabled vilynx_enabled" data-video="{&quot;context&quot;:&quot;inline&quot;,&quot;mpxId&quot;:&quot;1105288259709&quot;,&quot;canonical_url&quot;:&quot;https://www.today.com/video/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709&quot;,&quot;canonicalUrl&quot;:&quot;https://www.today.com/video/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709&quot;,&quot;legacy_url&quot;:&quot;https://www.today.com/video/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709&quot;,&quot;playerUrl&quot;:&quot;https://www.today.com/offsite/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709&quot;,&quot;ampPlayerUrl&quot;:&quot;https://player.today.com/offsite/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709&quot;,&quot;relatedLink&quot;:&quot;&quot;,&quot;sentiment&quot;:&quot;Neutral&quot;,&quot;shortUrl&quot;:&quot;https://www.today.com/video/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709&quot;,&quot;description&quot;:&quot;Duchess Kate said she and Prince William are delighted about Meghan Markle and Prince Harry&#x27;s upcoming nuptials! And, Markle is a big fan of Kate, too.&quot;,&quot;title&quot;:&quot;Duchess Kate is &#x27;thrilled&#x27; over Meghan Markle and Prince Harry&#x27;s engagement news!&quot;,&quot;thumbnail&quot;:&quot;https://media4.s-nbcnews.com/j/MSNBC/Components/Video/201711/1920_kate_Screen_Shot_2017-11-28_at_3-04-30_PM.today-inline-vid-featured-desktop.jpg&quot;,&quot;socialTitle&quot;:&quot;Duchess Kate is &#x27;thrilled&#x27; over Meghan Markle and Prince Harry&#x27;s engagement news!&quot;,&quot;seoHeadline&quot;:&quot;Duchess Kate is ‘thrilled’ over Meghan Markle and Prince Harry’s engagement news!&quot;,&quot;guid&quot;:&quot;x_tdy_TOV_NEWS_KATEREACTS_171128&quot;,&quot;newsNetwork&quot;:&quot;TODAY.com&quot;,&quot;videoType&quot;:&quot;Original&quot;,&quot;isSponsored&quot;:false,&quot;nativeAd&quot;:false,&quot;autoPlay&quot;:false,&quot;mezzVersion&quot;:1,&quot;embedCode&quot;:&quot;%3Cdiv%20style&#x3D;%22position:relative;%20padding-bottom:63%25;%20padding-bottom:-webkit-calc(56.25%25%20+%2050px);%20padding-bottom:calc(56.25%25%20+%2050px);%20height:%200;%22%3E%0A%20%20%20%20%3Ciframe%20style&#x3D;%22position:absolute;%20width:%20100%25;%20height:%20100%25;%22%0A%20%20%20%20src&#x3D;%22https://www.today.com/offsite/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709%22%20scrolling&#x3D;%22no%22%20frameborder&#x3D;%220%22%3E%3C/iframe%3E%0A%20%20%3C/div%3E&quot;,&quot;duration&quot;:42,&quot;pub_date&quot;:&quot;2017-11-28T20:03:39.000+0000&quot;,&quot;pub_date_user_facing&quot;:&quot;November 28th, 2017&quot;,&quot;videoAssets&quot;:[{&quot;format&quot;:&quot;MPEG4&quot;,&quot;publicUrl&quot;:&quot;//link.theplatform.com/s/2E2eJC/NWFMJzS4oqgS&quot;,&quot;width&quot;:0,&quot;height&quot;:0,&quot;bitrate&quot;:0,&quot;duration&quot;:42,&quot;durationISO&quot;:&quot;PT41S&quot;,&quot;assetType&quot;:&quot;OnceURL&quot;}],&quot;captionLinks&quot;:{},&quot;requiresCaptioning&quot;:false,&quot;hasCaptions&quot;:false,&quot;hasTranscript&quot;:false,&quot;transcript&quot;:&quot;&quot;,&quot;availabilityState&quot;:&quot;available&quot;}" data-mpxId="1105288259709"  data-video-state="available" vilynx-id="https://www.today.com/video/duchess-kate-is-thrilled-over-meghan-markle-and-prince-harry-s-engagement-news-1105288259709">
              <div class="player-l-headline">
                  <span class="player-headline-icon"><i class="icon-video-arrow"></i></span>
                    <h2 class="player-headline">Duchess Kate is &#x27;thrilled&#x27; over Meghan Markle and Prince Harry&#x27;s engagement news!</h2>
                  <small class="player-headline-cta">Play Video
                       - <span class="player-headline-duration">0:42</span>
                  </small>
              </div>
              <div class="player-l-headline">
                  <span class="player-headline-icon"><i class="icon-video-arrow"></i></span>
                    <h2 class="player-headline">Duchess Kate is &#x27;thrilled&#x27; over Meghan Markle and Prince Harry&#x27;s engagement news!</h2>
                  <small class="player-headline-cta">Play Video
                       - <span class="player-headline-duration">0:42</span>
                  </small>
              </div>
      
      
          <img class="player-tease-img"
            src="https://media4.s-nbcnews.com/j/MSNBC/Components/Video/201711/1920_kate_Screen_Shot_2017-11-28_at_3-04-30_PM.today-inline-vid-featured-desktop.jpg">
      
        </div>
      
      
      
      
      
                <section class="player-l-playlist j-video-feeds associated">
                  <h4 class="player-header-playlist associated">More video</h4>
                      <article class="player-l-tease j-video-tease" data-mpxid="1104450115935">
                        <a class="player-tease-link" href="https://www.nbcnews.com/video/meghan-markle-gushes-over-prince-harry-s-engagement-ring-1104450115935">
                          <figure class="player-tease">
                            <i class="player-tease-icon icon-video-play"></i>
                            <span class="player-tease-duration">2:03</span>
                            <img class="tease-icon-play" src="https://nodeassets.today.com/cdnassets/today-images/svg/video-play-white.svg" alt="Play" />
                      <noscript>
                                <img class="tease-image"
                                  src="https://media1.s-nbcnews.com/j/MSNBC/Components/Video/201711/f_meghan_harry_171127.today-vid-canonical-small-desktop.jpg"
                                  title="Diamonds From Diana: Markle gushes over ring designed by Harry"
                                  alt="Diamonds From Diana: Markle gushes over ring designed by Harry">
                              </noscript>
                              <img class="tease-image tease-image-placeholder j-lazy-img"
                                src="https://nodeassets.today.com/cdnassets/today-images/placeholder.png"
                                srcset="https://nodeassets.today.com/cdnassets/today-images/placeholder@2x.png 2x"
                                alt=""
                                data-src="https://media1.s-nbcnews.com/j/MSNBC/Components/Video/201711/f_meghan_harry_171127.today-vid-canonical-small-desktop.jpg"
                                data-title="Diamonds From Diana: Markle gushes over ring designed by Harry"
                                data-classes="tease-image tease-image-placeholder">      <small class="tease-sponsored">Sponsored Content</small>
                            <small class="tease-playing">Now Playing</small>
                          </figure>
                          <h2 class="player-tease-headline">Diamonds From Diana: Markle gushes over ring designed by Harry</h2>
                        </a>
                      </article>
                      <article class="player-l-tease j-video-tease" data-mpxid="1105064515936">
                        <a class="player-tease-link" href="//www.today.com/video/prince-harry-and-meghan-markle-like-lovesick-puppies-royal-expert-says-1105064515936">
                          <figure class="player-tease">
                            <i class="player-tease-icon icon-video-play"></i>
                            <span class="player-tease-duration">7:06</span>
                            <img class="tease-icon-play" src="https://nodeassets.today.com/cdnassets/today-images/svg/video-play-white.svg" alt="Play" />
                      <noscript>
                                <img class="tease-image"
                                  src="https://media1.s-nbcnews.com/j/MSNBC/Components/Video/201711/tdy_mk_news_harry_markle_171128.today-vid-canonical-small-desktop.jpg"
                                  title="Prince Harry and Meghan Markle ‘like lovesick puppies,’ royal expert says"
                                  alt="Prince Harry and Meghan Markle ‘like lovesick puppies,’ royal expert says">
                              </noscript>
                              <img class="tease-image tease-image-placeholder j-lazy-img"
                                src="https://nodeassets.today.com/cdnassets/today-images/placeholder.png"
                                srcset="https://nodeassets.today.com/cdnassets/today-images/placeholder@2x.png 2x"
                                alt=""
                                data-src="https://media1.s-nbcnews.com/j/MSNBC/Components/Video/201711/tdy_mk_news_harry_markle_171128.today-vid-canonical-small-desktop.jpg"
                                data-title="Prince Harry and Meghan Markle ‘like lovesick puppies,’ royal expert says"
                                data-classes="tease-image tease-image-placeholder">      <small class="tease-sponsored">Sponsored Content</small>
                            <small class="tease-playing">Now Playing</small>
                          </figure>
                          <h2 class="player-tease-headline">Prince Harry and Meghan Markle ‘like lovesick puppies,’ royal expert says</h2>
                        </a>
                      </article>
                      <article class="player-l-tease j-video-tease" data-mpxid="1105054275519">
                        <a class="player-tease-link" href="//www.today.com/video/meghan-markle-prince-harry-s-fiancee-everything-you-need-to-know-1105054275519">
                          <figure class="player-tease">
                            <i class="player-tease-icon icon-video-play"></i>
                            <span class="player-tease-duration">4:04</span>
                            <img class="tease-icon-play" src="https://nodeassets.today.com/cdnassets/today-images/svg/video-play-white.svg" alt="Play" />
                      <noscript>
                                <img class="tease-image"
                                  src="https://media2.s-nbcnews.com/j/MSNBC/Components/Video/201711/tdy_news_kelly_meghan_markle_171128_1920x1080.today-vid-canonical-small-desktop.jpg"
                                  title="Meghan Markle, Prince Harry’s fiancée: Everything you need to know"
                                  alt="Meghan Markle, Prince Harry’s fiancée: Everything you need to know">
                              </noscript>
                              <img class="tease-image tease-image-placeholder j-lazy-img"
                                src="https://nodeassets.today.com/cdnassets/today-images/placeholder.png"
                                srcset="https://nodeassets.today.com/cdnassets/today-images/placeholder@2x.png 2x"
                                alt=""
                                data-src="https://media2.s-nbcnews.com/j/MSNBC/Components/Video/201711/tdy_news_kelly_meghan_markle_171128_1920x1080.today-vid-canonical-small-desktop.jpg"
                                data-title="Meghan Markle, Prince Harry’s fiancée: Everything you need to know"
                                data-classes="tease-image tease-image-placeholder">      <small class="tease-sponsored">Sponsored Content</small>
                            <small class="tease-playing">Now Playing</small>
                          </figure>
                          <h2 class="player-tease-headline">Meghan Markle, Prince Harry’s fiancée: Everything you need to know</h2>
                        </a>
                      </article>
                      <article class="player-l-tease j-video-tease" data-mpxid="1105028675858">
                        <a class="player-tease-link" href="//www.today.com/video/prince-harry-and-meghan-markle-5-key-questions-about-their-wedding-1105028675858">
                          <figure class="player-tease">
                            <i class="player-tease-icon icon-video-play"></i>
                            <span class="player-tease-duration">2:44</span>
                            <img class="tease-icon-play" src="https://nodeassets.today.com/cdnassets/today-images/svg/video-play-white.svg" alt="Play" />
                      <noscript>
                                <img class="tease-image"
                                  src="https://media1.s-nbcnews.com/j/MSNBC/Components/Video/201711/tdy_news_royal_expert_171128_1920x1080.today-vid-canonical-small-desktop.jpg"
                                  title="Prince Harry and Meghan Markle: 5 key questions about their wedding"
                                  alt="Prince Harry and Meghan Markle: 5 key questions about their wedding">
                              </noscript>
                              <img class="tease-image tease-image-placeholder j-lazy-img"
                                src="https://nodeassets.today.com/cdnassets/today-images/placeholder.png"
                                srcset="https://nodeassets.today.com/cdnassets/today-images/placeholder@2x.png 2x"
                                alt=""
                                data-src="https://media1.s-nbcnews.com/j/MSNBC/Components/Video/201711/tdy_news_royal_expert_171128_1920x1080.today-vid-canonical-small-desktop.jpg"
                                data-title="Prince Harry and Meghan Markle: 5 key questions about their wedding"
                                data-classes="tease-image tease-image-placeholder">      <small class="tease-sponsored">Sponsored Content</small>
                            <small class="tease-playing">Now Playing</small>
                          </figure>
                          <h2 class="player-tease-headline">Prince Harry and Meghan Markle: 5 key questions about their wedding</h2>
                        </a>
                      </article>
                </section>
              
      
      </div>
      
            <p>
        Markle has played smart and tenacious attorney Rachel Zane on the legal drama since the show's 2011 debut.
      </p>
      
            <p>
        <a href="https://www.today.com/popculture/meghan-markle-s-suits-fiance-had-hilarious-response-her-engagement-t119329" target="_blank">Her "Suits" co-stars, including actor Patrick J. Adams, flocked to social media Monday</a> to send the actress their very best wishes — and to have some fun with the big news.
      </p>
      
            <div class="widget tweetembed">
        <blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">She said she was just going out to get some milk... <a href="https://t.co/y7cnM0eC9D">https://t.co/y7cnM0eC9D</a></p>— Patrick J Adams (@halfadams) <a href="https://twitter.com/halfadams/status/935168456957165568?ref_src=twsrc%5Etfw">November 27, 2017</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
      </div>
      
            <p>
        Adams, who played Markle's fiancé on the show, responded to the global headlines by joking, "She said she was just going out to get some milk..."
      </p>
      
            <p>
        He later circled back with a heartfelt note to <a href="https://www.today.com/popculture/meghan-markle-was-once-deal-or-no-deal-case-model-t119351" target="_blank">his leading lady</a> and her real-life prince.
      </p>
      
            <div class="widget tweetembed">
        <blockquote class="twitter-tweet" data-conversation="none" data-lang="en"><p lang="en" dir="ltr">Playing Meghanâs television partner for the better part of a decade uniquely qualifies me to say this: Your Royal Highness, you are a lucky man and I know your long life together will be joyful, productive and hilarious. Meghan, so happy for you, friend. Much love.</p>— Patrick J Adams (@halfadams) <a href="https://twitter.com/halfadams/status/935225535076057088?ref_src=twsrc%5Etfw">November 27, 2017</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
      </div>
      
            <p>
        "Playing Meghan’s television partner for the better part of a decade uniquely qualifies me to say this: Your Royal Highness, you are a lucky man and I know your long life together will be joyful, productive and hilarious," the actor wrote. "Meghan, so happy for you, friend. Much love."
      </p>
      
            <p>
        Congrats to Meghan on her <em>new</em> starring role!
      </p>
      
        </div>
      
      
        <div class="entry-bottom">
          <div class="entry-meta">
            <p class="entry-taxonomy">
              <strong>More: </strong>
                <span><a href="//www.today.com/popculture">Pop Culture</a></span>
                <span><a href="//www.today.com/popculture/tv">TV</a></span>
                <span><a href="//www.today.com/royals">Royals </a></span>
            </p>
          </div>
      
              <aside class="entry-social bottom j-share-bar-bottom" data-share-image-url="https://media3.s-nbcnews.com/i/newscms/2017_48/1299975/meghan-markle-today-171121-tease_79e1c5b624ea98df7b78a2c779eafbdb.jpg" data-share-url="//www.today.com/popculture/newly-engaged-meghan-markle-leaving-suits-after-season-7-t119387" data-share-headline="Meghan%20Markle%20leaving%20&#x27;Suits&#x27;%20because%20she%20has%20something%20else%20going%20on" data-section="popculture">
                
                <div class="btn btn-facebook j-facebook">
                  <i class="icon-facebook j-article-share j-facebook" platform="facebook"></i>
                  <span class="label-facebook j-facebook j-share-label">share</span>
                </div>
                
                <div class="btn btn-twitter j-twitter">
                  <i class="icon-twitter j-article-share j-twitter" platform="twitter"></i>
                  <span class="label-twitter j-twitter j-share-label">tweet</span>
                </div>
                
                <div class="btn btn-pinterest j-pinterest">
                  <i class="icon-pinterest j-article-share j-pinterest" platform="pinterest"></i>
                  <span class="label-pinterest j-pinterest j-share-label">pin</span>
                </div>
                
                <div class="btn btn-email j-email">
                  <i class="icon-email j-article-share j-email" platform="email"></i>
                  <span class="label-email j-email j-share-label">email</span>
                </div>
              </aside>
      
                <div class="article-newsletter">
                  
                  
                  
                  
                  
                    <div class="newsletter-l-wrapper">
                    	<div class="j_newsletter_subscribe" data-show_prompt="true" data-nlid="158" data-prompt_text="TODAY Pop Culture newsletter" data-placement="article_bottom">
                    	</div>
                    </div>
                </div>
                <div class="revpanel-belowarticle revpanel-desktop" id="revpanel-belowarticle-119387" data-component-name="revpanel-belowarticle"></div>
      
        </div>
      </article>

    <div class="j-player-l-container movable" id="ndp-player-container">
      <!-- Spinning Semi-circle -->
      <div class="loading-container">
      	<div class="loader">
      	  <div class="loading-circle"></div>
      	</div>
      </div>  <div id="js-control-rack-placeholder"></div>
    </div>
    <script type="text/template" id="js-control-rack">
      <% if ((isAd) || (isVideo && useDuringContent)) { %>
      	<% if ((lastMouseMove + hideDelay) > (currentTime)) { %>
      		<div class="video-scrubber">
      				<% if (isPlaying) { %>
      				<div class="btn-controls playpause btn-left control-pause">
      					<i class="icon-video-pause"></i>
      				<% } else { %>
      				<div class="btn-controls playpause btn-left control-play">
      					<i class="icon-video-arrow"></i>
      				<% } %>
      			</div>
      			<% if (isAd) { %>
      			<div class="ad-control">
      				<div class="center-content">
      					Your video begins in <div class="ad-time"><%- timeFormat(endTime-currentTime) %></div>
      				</div>
      			</div>
      			<% } %>
      			<% if (isVideo && !isAd) { %>
      			<div class="time-control">
      				<div class="time time-progress"><%- timeFormat(currentTime) %></div>
      				<div class="scrubber-wrapper">
      					<div class="scrubber">
      						<div id="scrubber-status" class="scrubber-status" style="width: <%= Math.floor((currentTime * 100) / endTime) %>%">&nbsp;</div>
      					</div>
      				</div>
      				<div class="time time-end"><%- timeFormat(endTime) %></div>
      			</div>
      			<div class="btn-right">
      				<% if (isDesktop) { %>
      					<% if (inMutedState) { %>
      					<div class="btn-controls sound control-volume-off">
      						<i class="icon-video-sound-off"></i>
      					<% } else { %>
      					<div class="btn-controls sound control-volume-on">
      						<i class="icon-video-sound-on"></i>
      					<% } %>
      					</div>
      				<% } %>
      				<div class="btn-controls cc control-cc">
      					<i class="icon-video-cc"></i>
      					<% if (showCaptionOptions) { %>
      						<div class="js-control-ccOptions">
      							<i class="icon-video-cc-options control-cc-options">Options</i>
      							<i class="icon-video-cc-english control-cc-english">English</i>
      							<i class="icon-video-cc-off control-cc-off">Off</i>
      						</div>
      					<% } %>
      				</div>
      					<% if (inFullscreenState) { %>
      					<div class="btn-controls fullscreen control-fullscreen control-exit-fullscreen">
      						<i class="icon-video-fullscreen"></i>
      					<% } else { %>
      					<div class="btn-controls fullscreen control-fullscreen control-enter-fullscreen">
      						<i class="icon-video-fullscreen"></i>
      					<% } %>
      				</div>
      			</div>
      			<% } %>
      		</div>
      	<% } %>
      <% } %>
    </script>

    <a id="scroll-to-top" href="#0"><span class="scroll-arrow"></span>TOP</a>
  </section>
</main>

        <footer class="site-footer">
            <ul class="more-l-wrapper">
            	<li class="more-item j-nav-more">
            		<a href="//www.today.com/about">About TODAY</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="http://visit.today.com">Visit TODAY</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="http://budurl.com/zdtTDYtdyns122216">TODAY store</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="//www.today.com/info/app">TODAY apps</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="//www.today.com/info/contact-us">Contact us</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="//www.today.com/sitemap">Sitemap</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="http://www.nbcunicareers.com">Jobs</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="//www.today.com/info/terms-and-conditions">Terms &amp; Conditions</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="http://www.nbcuni.com/privacy/full-privacy-policy">Privacy policy</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="//www.today.com/info/closed-captioning">Closed captioning</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a href="http://together.nbcuni.com" target="_blank">Advertise</a>
            	</li>
            	<li class="more-item j-nav-more">
            		<a id="_bapw-link" href="http://info.evidon.com/pub_info/1241?" target="_blank"><img id="_bapw-icon" src="//c.betrad.com/pub/icon1.png">&nbsp;AdChoices</a>
            	</li>
            </ul>	<ul class="brand-l-wrapper">
        		<li class="brand-item j-nav-brand brand-cnbc"><a href="http://cnbc.com/"><i class="icon-cnbc-logo"></i></a></li>
        		<li class="brand-item j-nav-brand brand-msnbc"><a href="http://msnbc.com/"><i class="icon-msnbc-tv"></i></a></li>
        		<li class="brand-item j-nav-brand brand-nbcnews"><a href="http://nbcnews.com/"><i class="icon-nbcnews-logo"></i></a></li>
        		<li class="brand-item j-nav-brand brand-today"><a href="http://www.today.com/"><i class="icon-today-logo"></i></a></li>
        		<li class="brand-item j-nav-brand brand-xfinity"><a href="http://xfinity.com/"><i class="icon-xfinity-logo"></i></a></li>
        	</ul>
        </footer>    </div>

      <script id="mps-ext-load" type="text/javascript">
        var mpscall = { site:'todayshow', 'cag[device]':'desktop' },
            mpsopts = { host:'mps.nbcnews.com' },
            mps = mps || {};
    
        mpscall['cag[primary_section]'] = 'popculture';
        mpscall['cag[primary_topic]'] = 'tv';
        mpscall['cag[primary_subtopic]'] = '';
        mpscall['cag[primary_label]'] = 'royals';
        mpscall['cag[primary_show]'] = '';
        mpscall['cag[entryno]'] = '1';
        mpscall['type'] = 'post';
        mpscall['is_content'] = '1';
        mpscall['cag[breaking_news]'] = '0';
        mpscall['cag[byline]'] = 'Gina Vivinetto';
        mpscall['cag[series]'] = '';
        mpscall['cag[anchors]'] = '';
        mpscall['cag[shows]'] = '';
        mpscall['cag[sections]'] = 'popculture|news';
        mpscall['cag[labels]'] = 'royals';
        mpscall['cag[topics]'] = 'tv';
        mpscall['cag[subtopics]'] = '';
        mpscall['cag[external_id]'] = '119387';
        mpscall['taxonomy'] = 'popculture,tv';
        mpscall['cat'] = 'popculture|tv';
        mpscall['path'] = '/popculture/tv/newly-engaged-meghan-markle-leaving-suits-after-season-7-119387';
    
        document.write('<scr' + 'ipt id="mps-ext-load" src="//' + mpsopts.host + '/fetch/ext/load-' + mpscall.site + '.js"></scr' + 'ipt>');
        // I am using this value below when I load more ads
        var mpsload = { src:'//' + mpsopts.host + '/fetch/ext/load-' + mpscall.site + '.js?nowrite=jq' };
      </script>

      <script>
        function loadCSS(url) {
          var link = document.createElement("link");
          link.type = "text/css";
          link.rel = "stylesheet";
          link.href = url;
          document.getElementsByTagName("head")[0].appendChild(link);
        }
        setTimeout(function(){
          loadCSS("https://nodeassets.today.com/styles/secondary-88bc0a721a.min.css");
        },0);
      </script>

    <script src="//assets.adobedtm.com/cd771b0aa897f931a306d7ab6af0d448836b5fd1/satelliteLib-db4c230822fb4e54d9ac312fcb48017ee99e47d3.js"></script>
    <script src="https://nodeassets.today.com/scripts/config/vendor-7c01052521.min.js"></script>
    <script type="text/javascript">
      (function ($) {
        Tdy = window.Tdy || {};
        Tdy.NDPSiteData = Tdy.NDPSiteData  || {};
        Tdy.NDPSiteData.siteData = Tdy.NDPSiteData.siteData || {};
      }(window.jQuery));
    </script>



        <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
        
            <script src="https://nodeassets.today.com/scripts/desktop/entrypage-2361553aa9.min.js"></script>
        
        







    <script type="text/javascript">
      if(window._satellite && typeof analyticsDataLayer !== 'undefined') {
        _satellite.pageBottom();

        if(analyticsDataLayer.page == 'search'){
            _satellite.track('search');
        } else if (analyticsDataLayer.page === 'slideshow') {
            _satellite.track('slideshow_page');
        } else if (analyticsDataLayer.page === 'recipe'){
            _satellite.track('articleView');
        } else if (analyticsDataLayer.page !== 'article') {
            _satellite.track('standard');
        }
      }
    </script>

    <script>
      if (typeof mps !== 'undefined' && typeof (mps.writeFooter) === 'function') {
          mps.writeFooter();
      }
    </script>

        <script src="//nvcdn.today.com/_elliott/jenga?widgets=core,zinger2,content,newsletter,social,fivestar,troff"></script>
        <link type="text/css" rel="stylesheet" href="//nvcdn.today.com/_elliott/jenga_css?widgets=core,zinger2,content,newsletter,social,fivestar,troff">
    <script src="https://jetpack.nbcnews.com/prod/Servejetpack?bucket=jetpack-rev&bundle=jetpack-master/today"></script>
</body>
</html>
<!-- requestedAt: 2017-11-29T00:44:55.051Z; executionTime: 587; ra: ws; -->